summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2014-04-14 14:27:32 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2014-04-14 11:49:49 -0700
commit019edd065fd1eefd5f705c42bce23255bb5e20ac (patch)
tree7152ff352630d4eeab654f6c2e7307fb1e982cb3 /CMakeLists.txt
parent907d8b8fbbb0bc07ccc4c4b4d1374f764c5d8dae (diff)
downloadsubsurface-019edd065fd1eefd5f705c42bce23255bb5e20ac.tar.gz
First test case implemented.
This is just a stub test case to show how a test case should be implemented. every 'private slot' on the test classes will be automatically executed when you run 'make test' on the terminal, and a report will be generated with a failure / success. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 35736e674..35fc9ee18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,3 +114,6 @@ ADD_DEPENDENCIES(subsurface_interface subsurface_generated_ui)
ADD_DEPENDENCIES(subsurface_generated_ui version)
ENABLE_TESTING()
+ADD_EXECUTABLE( TestUnitConversion tests/testunitconversion.cpp )
+TARGET_LINK_LIBRARIES( TestUnitConversion ${QT_LIBRARIES})
+ADD_TEST( NAME TestUnitConversion COMMAND TestUnitConversion) \ No newline at end of file