summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-05 21:10:40 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-05 21:10:40 -0700
commit143ecbf7a2a4949228678c74bb49e1c52cc00812 (patch)
treee1a8aa39a35c41921a96aaa2d88d3f33a7f43362 /CMakeLists.txt
parentf8a01ee3095513ddbea0fa53ed6768ae0dbe9913 (diff)
downloadsubsurface-143ecbf7a2a4949228678c74bb49e1c52cc00812.tar.gz
cmake: second attempt to install our ssrfmarble lib
Sorry for the noise. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3c2fc7bb..09cd20b4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -578,6 +578,9 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
install(FILES ${TRANSLATIONS} DESTINATION share/subsurface/translations)
install(TARGETS ${SUBSURFACE_TARGET} DESTINATION bin)
IF(DEFINED LIBMARBLEDEVEL)
- install(FILES ${LIBMARBLEDEVEL}/lib/libssrfmarblewidget.so* DESTINATION lib)
+ install(
+ CODE "file(GLOB SSRFMARBLE_SHLIBS \"${LIBMARBLEDEVEL}/lib/libssrfmarblewidget.so*\")"
+ CODE "file(INSTALL \${SSRFMARBLE_SHLIBS} DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)"
+ )
ENDIF()
ENDIF()