summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-03-25 14:48:02 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-03-25 14:48:02 -0700
commit405e52fef9d4a8eec16554496dfd8e8bad0476aa (patch)
tree3bb46461716ad2b30ad089508f88195713a0c183 /CMakeLists.txt
parent24a1ab461b9fd24b632f18734c4270972e481b4f (diff)
downloadsubsurface-405e52fef9d4a8eec16554496dfd8e8bad0476aa.tar.gz
cmake: handle libzip like the other libraries
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0752ceef5..2353d2742 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,7 @@ ELSE()
ENDIF()
ENDIF()
pkg_config_library(LIBXSLT libxslt)
+pkg_config_library(LIBZIP libzip)
SET(LIBDCDEVEL "" CACHE STRING "libraries")
IF(DEFINED LIBDCDEVEL)
@@ -256,7 +257,6 @@ target_link_libraries( subsurface
subsurface_statistics
subsurface_corelib
${SUBSURFACE_LINK_LIBRARIES}
- -lzip
)
ADD_DEPENDENCIES(subsurface_statistics subsurface_generated_ui)
@@ -267,7 +267,7 @@ ADD_DEPENDENCIES(subsurface_corelib version)
MACRO(test NAME FILE)
ADD_EXECUTABLE(${NAME} tests/${FILE} ${SUBSURFACE_RESOURCES})
- TARGET_LINK_LIBRARIES(${NAME} subsurface_corelib ${QT_TEST_LIBRARIES} ${SUBSURFACE_LINK_LIBRARIES} -lzip )
+ TARGET_LINK_LIBRARIES(${NAME} subsurface_corelib ${QT_TEST_LIBRARIES} ${SUBSURFACE_LINK_LIBRARIES})
ADD_TEST(NAME ${NAME} COMMAND ${NAME})
ENDMACRO()