summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-05 17:41:35 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-05 17:41:35 -0700
commit5722d5f0dc40f850c517e412e6bb44bdc73c3749 (patch)
treebbf44ffc2ff6d257f2d6d45a3fe03db8069b3e03 /CMakeLists.txt
parent352433723dc98269a4b206072b7fd18d6dba436e (diff)
downloadsubsurface-5722d5f0dc40f850c517e412e6bb44bdc73c3749.tar.gz
cmake: add libz to end of linker line on Linux
While I don't need this when building on Fedora 20, OBS builds for openSUSE appear to fail without this. Strange. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fa7365cc..6c1cae29b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,6 +155,8 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
if(NOT DEFINED LRELEASE)
set(LRELEASE lrelease)
endif()
+ # in some builds we appear to be missing libz for some strange reason...
+ set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lz)
ENDIF()
IF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(SUBSURFACE_TARGET Subsurface)