summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gehad elrobey <gehadelrobey@gmail.com>2015-04-21 17:23:13 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-04 10:07:25 -0700
commite2ad38189eb81eda213f775302efb44d2ed70c85 (patch)
tree8cb65bf053d7b1aa72d54ac4b80ee99b52297bc4 /CMakeLists.txt
parent00f4b7b66b43d77119f004b08471b72c4ce4bab5 (diff)
downloadsubsurface-e2ad38189eb81eda213f775302efb44d2ed70c85.tar.gz
Printing: Add TemplateLayout class
This is the main class to hold Grantlee engine logic. TemplateLayout::generate() loads QT5Grantlee and initialize the templates then returns a QString that contains the rendered HTML by Grantlee library. Also this class contains the Dive class which holds the logic that formats the data before passing it to the templates. Signed-off-by: Gehad elrobey <gehadelrobey@gmail.com> Signed-off-by: Lubomir I. Ivanov <neolit123@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f69176fe7..a93ccbab5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -260,6 +260,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
configuredivecomputer.cpp
configuredivecomputerthreads.cpp
divesitehelpers.cpp
+ templatelayout.cpp
${PLATFORM_SRC}
)
source_group("Subsurface Core" FILES ${SUBSURFACE_CORE_LIB_SRCS})