summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-08-31 20:19:06 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-08-31 18:41:14 -0700
commitab32295f8906ae5b6334f7abc8d05032b68ae577 (patch)
tree7905a5fbcefc438d12253f0ff65312b785008dff /CMakeLists.txt
parent5db6d415986ffacf199f75e10d277934d3ff5a7b (diff)
downloadsubsurface-ab32295f8906ae5b6334f7abc8d05032b68ae577.tar.gz
Add a new model: SsrfFilterProxyModel
Add a new Model, it's the QSortFilterProxyModel that accepts functions to filter / sort. so instead of creating a new class for each different sorting (overkill), now we can just create a function and pass to this class. I'll rework the filtering system of subsurface to use this - in the meantime I've created this to ease the creation of another filter: the dive sites by gps coordinates. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c0374f1e0..1426040ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -390,6 +390,7 @@ set(SUBSURFACE_MODELS_LIB_SRCS
qt-models/diveplotdatamodel.cpp
qt-models/divelocationmodel.cpp
qt-models/divesitepicturesmodel.cpp
+ qt-models/ssrfsortfilterproxymodel.cpp
)
source_group("Subsurface Models" FILES ${SUBSURFACE_MODELS})