summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-27 15:28:27 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-27 15:28:27 -0700
commit9f86468c00bb1e1c9c904a1142d7406dc86af28d (patch)
tree6c597ee30270bbab37ae363f9c6cd684511a12fe /CMakeLists.txt
parentfeb15a5498c640651bf48781d828d8fed79a2412 (diff)
downloadsubsurface-9f86468c00bb1e1c9c904a1142d7406dc86af28d.tar.gz
Make sure the output directory is created before we run asciidoc
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2629590e..943de13ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -517,11 +517,19 @@ if(NOT insource)
ln -s ${CMAKE_SOURCE_DIR}/Documentation/images ${CMAKE_BINARY_DIR}/Documentation/images
)
endif()
+else()
+ if(NOT NO_DOCS)
+ add_custom_target(
+ documentationLink ALL
+ )
+ endif()
endif()
if(NOT NO_DOCS)
add_custom_target(
documentation ALL
+ COMMAND
make -C ${CMAKE_SOURCE_DIR}/Documentation OUT=${CMAKE_BINARY_DIR}/Documentation/ doc
+ DEPENDS documentationLink
)
endif()