summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Anton Lundin <glance@acc.umu.se>2015-08-21 00:19:44 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-08-20 22:59:49 -0700
commite2c98def2699c6ed4b98633f780ef3faaf903335 (patch)
tree98fb5fd775f4092594f9d21e6b7d1df87a5b0491 /CMakeLists.txt
parent3104508247848799449c41e87d87fc258db3d8da (diff)
downloadsubsurface-e2c98def2699c6ed4b98633f780ef3faaf903335.tar.gz
Turn serial_ftdi.c into a custom_serial
This cleans up serial_ftdi.c from being a libdivecomputer source and making it into a subsurface custom_serial. Signed-off-by: Anton Lundin <glance@acc.umu.se> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index deec8b397..92f9e94b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -260,6 +260,8 @@ endif()
if(ANDROID)
set(PLATFORM_SRC android.cpp)
set(SUBSURFACE_TARGET subsurface)
+ # To allow us to debug log to logcat
+ set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -llog)
endif()
if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(SUBSURFACE_TARGET Subsurface)