summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-08-21 10:02:27 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-08-21 10:16:06 -0700
commite86fd45efde7e8314b8045cb88495c48838bb4bd (patch)
treea43aceb9e6ff5eb145e6f5e4d5920a0b3d502745 /CMakeLists.txt
parent3437666010c3c9c725644e5d789cbb0faa3794c2 (diff)
downloadsubsurface-e86fd45efde7e8314b8045cb88495c48838bb4bd.tar.gz
Cmake: fix cross compiling on Windows
Cmake has a bug that causes the moc process not being handed the necessary defines for the architecture we are building for. Also we were missing a library to make the BT implementation on Windows work. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c74e3551..1a2270bf7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -294,9 +294,9 @@ endif()
if(CMAKE_SYSTEM_NAME STREQUAL "Windows")
set(SUBSURFACE_TARGET subsurface)
set(PLATFORM_SRC windows.c)
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lwsock32)
+ set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lwsock32 -lws2_32)
remove_definitions(-DUNICODE)
- add_definitions(-mwindows)
+ add_definitions(-mwindows -D_WIN32)
endif()
# include translations