summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-12-17 17:14:13 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-17 11:48:15 -0800
commit13573915b686cd327ad61e611e87f5677b60174e (patch)
tree624e7f90769a60db560c33e831eb36bea94a7bfc /CMakeLists.txt
parent8abbcc55983ba5f9a0b2cd88b11be6ff6acc7b6a (diff)
downloadsubsurface-13573915b686cd327ad61e611e87f5677b60174e.tar.gz
Fix CMake to not add Facebook on Android
Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 989e8610b..7bf638399 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -129,7 +129,6 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
endif()
if(ANDROID)
- set(FBSUPPORT OFF)
set(NO_PRINTING ON)
list(APPEND QT_EXTRA_COMPONENTS AndroidExtras)
list(APPEND QT_EXTRA_LIBRARIES Qt5::AndroidExtras)
@@ -208,11 +207,6 @@ if (${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
add_subdirectory(desktop-widgets)
endif()
-if(FBSUPPORT)
- add_definitions(-DFBSUPPORT)
- set(FACEBOOK_INTEGRATION facebook_integration)
-endif()
-
# create the executables
if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
set(SUBSURFACE_TARGET subsurface-mobile)