summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-04-07 17:20:27 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-07 16:07:33 -0700
commit2e05dbb791740d308c2479562ce13de4087e62d1 (patch)
treedb84931803dd2c5558d5787d93d7a93b3cfc485e /CMakeLists.txt
parentf13e72c306a4cd0728c4f64b09f13f1b4f462557 (diff)
downloadsubsurface-2e05dbb791740d308c2479562ce13de4087e62d1.tar.gz
No need to specify Marble dir anymore
We are already looking for the default directory. *if* cmake doesn't find Marble automatically, the user needs to specify -DMARBLE_INCLUDE_DIR and -DMARBLE_LIBRARIES Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ba2d3381..4b434f570 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,15 +53,8 @@ ELSE()
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -ldivecomputer)
ENDIF()
-IF(NOT DEFINED LIBMARBLEDEVEL)
- FIND_PACKAGE(Marble REQUIRED)
- include_directories(${MARBLE_INCLUDE_DIR})
- link_directories(${MARBLE_LIB_DIR})
-ELSE()
- include_directories(${LIBMARBLEDEVEL}/include)
- link_directories(${LIBMARBLEDEVEL}/lib)
- SET(MARBLE_LIBRARIES -L${LIBMARBLEDEVEL}/lib -lssrfmarblewidget)
-ENDIF()
+FIND_PACKAGE(Marble REQUIRED)
+include_directories(${MARBLE_INCLUDE_DIR})
# handle out of tree build correctly