summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-18 18:30:55 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-18 18:34:49 -0800
commit456cc3955a3e343ea1d2303484d5c79b44635155 (patch)
tree4a48b0d244be602d1043c3e86b89d0b700f9afc2 /CMakeLists.txt
parent0b804e5b215f94a924f0d516da25dc46a81e710d (diff)
downloadsubsurface-456cc3955a3e343ea1d2303484d5c79b44635155.tar.gz
Location service: move into subsurface-core
While this is primarily something targeted at a mobile device, with many of the 2 in 1 devices it is possible that the user might be running the desktop version of Subsurface on a mobile device. As a first step to make it possible to collect GPS fixes on such a device we need to make the infrastructure to do so available in the desktop application as well. This still needs to be hooked up in the desktop UI. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d2248f5b..9ee3eb829 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -208,8 +208,6 @@ endif()
if(SUBSURFACE_MOBILE)
set(QT_QUICK_PKG Quick)
set(QT_QUICK_LIB Qt5::Quick)
- set(QT_LOCATION_PKG Location)
- set(QT_LOCATION_LIB Qt5::Positioning)
add_definitions(-DSUBSURFACE_MOBILE)
endif()
if(ANDROID)
@@ -220,8 +218,8 @@ if(BTSUPPORT)
set(BLUETOOTH_PKG Bluetooth)
set(BLUETOOTH_LIB Qt5::Bluetooth)
endif()
-find_package(Qt5 REQUIRED COMPONENTS Core Concurrent Widgets Network ${WEBKIT_PKG} ${PRINTING_PKG} Svg Test LinguistTools ${QT_QUICK_PKG} ${ANDROID_PKG} Bluetooth ${QT_LOCATION_PKG})
-set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} ${PRINTING_LIB} Qt5::Svg ${QT_QUICK_LIB} ${ANDROID_LIB} Qt5::Bluetooth ${QT_LOCATION_LIB})
+find_package(Qt5 REQUIRED COMPONENTS Core Concurrent Widgets Network ${WEBKIT_PKG} ${PRINTING_PKG} Svg Test LinguistTools ${QT_QUICK_PKG} ${ANDROID_PKG} Bluetooth Location)
+set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} ${PRINTING_LIB} Qt5::Svg ${QT_QUICK_LIB} ${ANDROID_LIB} Qt5::Bluetooth Qt5::Positioning)
set(QT_TEST_LIBRARIES ${QT_LIBRARIES} Qt5::Test)
if (BTSUPPORT AND "${Qt5Core_VERSION_STRING}" STRLESS "5.4.0")
@@ -359,7 +357,6 @@ if(SUBSURFACE_MOBILE)
set(MOBILE_SRC
qt-mobile/qmlmanager.cpp
qt-mobile/qmlprofile.cpp
- qt-mobile/gpslocation.cpp
qt-models/divelistmodel.cpp
subsurface-mobile-main.cpp
subsurface-mobile-helper.cpp