summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-12-17 17:04:52 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-17 11:47:50 -0800
commit8abbcc55983ba5f9a0b2cd88b11be6ff6acc7b6a (patch)
tree5057b9a28eeb2d0a524fcbf50c7b419fdd9282c9 /CMakeLists.txt
parent9e39213ed115bbb202e1dcf3b9ad57da7b41a8d0 (diff)
downloadsubsurface-8abbcc55983ba5f9a0b2cd88b11be6ff6acc7b6a.tar.gz
Add the correct target on the Android build
The android build could be the Desktop and the Mobile app, we cannot force it to be the mobile. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 983d48b3b..989e8610b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -320,7 +320,7 @@ if(ANDROID)
# Android template directory
include(${QT_ANDROID_CMAKE})
set(ANDROID_PACKAGE_SOURCE_DIR, ${CMAKE_BINARY_DIR}/android-mobile)
- add_qt_android_apk(subsurface-mobile.apk subsurface-mobile
+ add_qt_android_apk(subsurface-mobile.apk ${SUBSURFACE_TARGET}
PACKAGE_SOURCES ${CMAKE_CURRENT_LIST_DIR}/android-mobile
)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")