summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Guillaume GARDET <guillaume.gardet@free.fr>2016-07-21 12:55:23 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-07-23 10:54:36 +0900
commit8b35defa48514e2695d1fc8a26aee0a30d2dd1b9 (patch)
treecfe9bdefac11456338ba723b66e4a0d4a78c08c5 /CMakeLists.txt
parent493fefef712241f208fa1f3f939579dfe3d66dcf (diff)
downloadsubsurface-8b35defa48514e2695d1fc8a26aee0a30d2dd1b9.tar.gz
Fix build (link) on openSUSE builds (maybe due to recent cmake version)
Signed-off-by: Guillaume GARDET <guillaume.gardet@free.fr> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43d817c31..7aac06f6b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,7 +150,8 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Linux")
# this is only needed on Ubuntu
# but shouldn't hurt on other Linux versions
# in some builds we appear to be missing libz for some strange reason...
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lz -lpthread)
+ # Add ssh2 at the end for openSUSE builds (for recent cmake?)
+ set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lssh2 -lz -lpthread)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
execute_process(
COMMAND sh scripts/get-version linux