summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2016-09-22 17:12:49 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-09-22 17:12:49 -0700
commit8cc7e6330934f3928256cb59914dde2413f2dcc8 (patch)
tree77d26551c4cdc89993ae281f3759689c83acc300 /CMakeLists.txt
parent131c5a2abe151493b23b42469834aa5c9891459b (diff)
downloadsubsurface-8cc7e6330934f3928256cb59914dde2413f2dcc8.tar.gz
Add commented out hack to dump all CMake variables
I use this all the time when debugging CMake issues. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09afcf882..06d9f6dd2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -447,3 +447,11 @@ endif()
if (MAKE_TESTS)
add_subdirectory(tests)
endif()
+
+# useful for debugging CMake issues
+#
+# message(STATUS "print variables")
+# get_cmake_property(_variableNames VARIABLES)
+# foreach(_variableName ${_variableNames})
+# message(STATUS "${_variableName}=${${_variableName}}")
+# endforeach()