summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-30 09:55:24 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-30 09:55:24 -0800
commit98fb625667e664fb4ec3f20f1feaa146ebbfd023 (patch)
tree478f76c1d9139c0ec17187e008fad3a8750ae4ca /CMakeLists.txt
parent4ad090565a4e5073f7c37115f348d2726c9405f4 (diff)
downloadsubsurface-98fb625667e664fb4ec3f20f1feaa146ebbfd023.tar.gz
Cmake: only need Marble/Grantlee/Manual for desktop version
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33ee56e64..ec0aa2caf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,10 +88,12 @@ include(cmake/Modules/pkgconfig_helper.cmake)
# module file.
include(cmake/Modules/HandleFindGit2.cmake)
include(cmake/Modules/HandleFindLibDiveComputer.cmake)
-include(cmake/Modules/HandleFindMarble.cmake)
-include(cmake/Modules/HandleFindGrantlee.cmake)
+if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
+ include(cmake/Modules/HandleFindMarble.cmake)
+ include(cmake/Modules/HandleFindGrantlee.cmake)
+ include(cmake/Modules/HandleUserManual.cmake)
+endif()
include(cmake/Modules/HandleFtdiSupport.cmake)
-include(cmake/Modules/HandleUserManual.cmake)
include(cmake/Modules/HandleVersionGeneration.cmake)
include(cmake/Modules/RunOnBuildDir.cmake)