summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-01-22 16:59:11 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-01-22 16:59:23 -0800
commitd62e46134daaee0479e70af38e6ab0c4fbe660a5 (patch)
treee3e547029f0fe05d210927b15dbad7278e4b749c /CMakeLists.txt
parentfc60f210c4a1966548b4227389e3110086c1e91b (diff)
downloadsubsurface-d62e46134daaee0479e70af38e6ab0c4fbe660a5.tar.gz
QML UI: allow building Subsurface-mobile on desktop
Since we manually track Kirigami we need to compile the desktopicon.cpp file when not building on Android or iOS. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29fcd0bac..d32606149 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -242,6 +242,9 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
subsurface-mobile-main.cpp
subsurface-mobile-helper.cpp
)
+ if(NOT ANDROID AND NOT iOS)
+ set(MOBILE_SRC ${MOBILE_SRC} mobile-widgets/qml/kirigami/src/desktopicon.cpp)
+ endif()
add_definitions(-DKIRIGAMI_BUILD_TYPE_STATIC)
qt5_add_resources(MOBILE_RESOURCES mobile-widgets/qml/mobile-resources.qrc)
qt5_add_resources(MOBILE_RESOURCES mobile-widgets/qml/kirigami/kirigami.qrc)