summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rex Dieter <rdieter@fedoraproject.org>2015-11-05 13:54:08 -0600
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-05 13:45:50 -0800
commitfcf47552c641facce196c4e96d4634daff6cfd11 (patch)
treea2d13628d90e0b45ac5bf75e14935d45a7f54a03 /CMakeLists.txt
parent3ebbf6bc5d33d7f245b79d77f7269ac609bf1c12 (diff)
downloadsubsurface-fcf47552c641facce196c4e96d4634daff6cfd11.tar.gz
Use target_link_libraries for Grantlee
This allows for finding headers when not in /usr/include (like parallel-installable distribution-packaged grantlee5) Signed-off-by: Rex Dieter <rdieter@fedoraproject.org> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57a10c461..35b0299ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -185,7 +185,7 @@ else()
set(WEBKIT_LIB Qt5::WebKitWidgets)
endif()
-set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${GRANTLEE_LIBRARIES} ${LIBUSB_LIBRARIES})
+set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${LIBUSB_LIBRARIES})
# handle out of tree build correctly
string(COMPARE EQUAL "${${PROJECT_NAME}_SOURCE_DIR}" "${${PROJECT_NAME}_BINARY_DIR}" insource)