summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-05 23:26:39 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-06 00:01:30 +0100
commit05f4f9b5336412a222672f460d87740f8ce7866c (patch)
tree71009b09a1b0b2ecdd34a3668ad4d1ab6f8290e5 /CMakeLists.txt
parent5861da0bce842bcca9777cad5d41bea790d6c5da (diff)
downloadsubsurface-05f4f9b5336412a222672f460d87740f8ce7866c.tar.gz
Cmake: ensure marbledata is actually copied into the build directory
This can be done regarless of whether Marble is enabled or not. No harm done. Fixes #937 Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a90d11c7f..b3c791223 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,9 +191,7 @@ endif()
get_filename_component(PARENTDIR ${${PROJECT_NAME}_SOURCE_DIR} PATH)
string(COMPARE EQUAL "${${PROJECT_NAME}_SOURCE_DIR}" "${PARENTDIR}" insourcesubdir)
if(NOT (insource OR insourcedir))
- if(NOT NO_MARBLE)
- add_custom_target(link_marble_data ALL COMMAND rm -rf ./marbledata && ln -s ${${PROJECT_NAME}_SOURCE_DIR}/marbledata ${${PROJECT_NAME}_BINARY_DIR}/marbledata)
- endif()
+ add_custom_target(link_marble_data ALL COMMAND rm -rf ./marbledata && ln -s ${CMAKE_SOURCE_DIR}/marbledata ${CMAKE_BINARY_DIR}/marbledata)
endif()
# configure Qt.