summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-16 14:24:47 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-16 14:24:47 -0800
commit44990671f17d08d68487f48a4cfd2abf7f8b9c3b (patch)
tree2ef811d7e9b47fdd9a968121525507163f5ba635 /CMakeLists.txt
parentec48e9ce5a8f872bcdb46bfa48c99533d0ba8c54 (diff)
downloadsubsurface-44990671f17d08d68487f48a4cfd2abf7f8b9c3b.tar.gz
Cmake: correctly read in the enabled translations
FILE READ doesn't do what we want. It's the STRINGS command that considers \n as whitespace and gets the correct result. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4992f4da1..c1211664c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -298,7 +298,7 @@ set(DOCFILES
${CMAKE_BINARY_DIR}/Documentation/user-manual_ru.html
)
-FILE(READ "subsurface_enabled_translations" QTTRANSLATIONS_BASE)
+FILE(STRINGS "subsurface_enabled_translations" QTTRANSLATIONS_BASE)
if(NOT DEFINED QT_TRANSLATION_DIR OR QT_TRANSLATION_DIR STREQUAL "")
set(QT_TRANSLATION_DIR ${Qt5Core_DIR}/../../../translations)