summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2014-08-25 14:52:45 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2014-08-25 13:55:23 -0700
commit537b42e3f7922e41cf3851b297033cc1f07fb922 (patch)
tree6b051de12398560fe6e2a4d254deaa24d1a65da8 /CMakeLists.txt
parentb1a92ccedf218f9c894f1d720a890373391bca93 (diff)
downloadsubsurface-537b42e3f7922e41cf3851b297033cc1f07fb922.tar.gz
Add initial skeleton for the Statistics Redesign
The statistics widget is a beast, one of the parts that I dislike most on the current subsurface implementation. This is the initial work to change that to something amazing. This first commit adds the first bunch of files that I think are needed, and the correct setup for the qmake and cmake buildsystems. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44fa1343a..2eef2d055 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,6 +164,14 @@ SET(SUBSURFACE_PROFILE_LIB_SRCS
qt-ui/profile/tankitem.cpp
)
+#the yearly statistics widget.
+SET(SUBSURFACE_STATISTICS_LIB_SRCS
+ qt-ui/statistics/statisticswidget.cpp
+ qt-ui/statistics/yearstatistics.cpp
+ qt-ui/statistics/statisticsbar.cpp
+ qt-ui/statistics/monthstatistics.cpp
+)
+
#the main app.
SET(SUBSURFACE_APP
main.cpp
@@ -182,6 +190,7 @@ ENDIF()
ADD_LIBRARY(subsurface_corelib STATIC ${SUBSURFACE_CORE_LIB_SRCS} )
ADD_LIBRARY(subsurface_profile STATIC ${SUBSURFACE_PROFILE_LIB_SRCS})
+ADD_LIBRARY(subsurface_statistics STATIC ${SUBSURFACE_STATISTICS_LIB_SRCS})
ADD_LIBRARY(subsurface_generated_ui STATIC ${SUBSURFACE_UI_HDRS})
ADD_LIBRARY(subsurface_interface STATIC ${SUBSURFACE_INTERFACE})
ADD_EXECUTABLE(subsurface ${SUBSURFACE_APP} ${SUBSURFACE_QRC_HRDS} )
@@ -190,6 +199,7 @@ target_link_libraries( subsurface
subsurface_generated_ui
subsurface_interface
subsurface_profile
+ subsurface_statistics
subsurface_corelib
${QT_LIBRARIES}
${MARBLE_LIBRARIES}
@@ -198,6 +208,7 @@ target_link_libraries( subsurface
-lzip
)
+ADD_DEPENDENCIES(subsurface_statistics subsurface_generated_ui)
ADD_DEPENDENCIES(subsurface_profile subsurface_generated_ui)
ADD_DEPENDENCIES(subsurface_interface subsurface_generated_ui)
ADD_DEPENDENCIES(subsurface_generated_ui version)