summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-08-24 09:32:27 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-08-25 10:43:41 -0700
commit6eed3155e6a84f1b27b5340b45d6deb801fee42d (patch)
treed22bc1723f296880327e607bf73f15d24b8ef74a /CMakeLists.txt
parenteb205c1b090b94f4812358c8835065491d149c6b (diff)
downloadsubsurface-6eed3155e6a84f1b27b5340b45d6deb801fee42d.tar.gz
Add simple test for git storage
This just makes sure that writing data to git storage and reading it back gives you the same result. Without the fixed generation of initial dive site UUIDs this fails. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a2270bf7..da98a218d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -571,6 +571,7 @@ if(NOT NO_TESTS)
TEST(TestProfile testprofile.cpp)
TEST(TestGpsCoords testgpscoords.cpp)
TEST(TestParse testparse.cpp)
+ TEST(TestGitStorage testgitstorage.cpp)
TEST(TestPlan testplan.cpp)
endif()