summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-17 11:08:21 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-17 11:49:58 -0800
commit7c095419f7f30203995fedcde23da6d541cf078c (patch)
tree054ba3c31e9865b0e6a503b04fd1833b8ede0b6b /CMakeLists.txt
parentd0b526eda49573a0fe1f5811522ec3f1ff503196 (diff)
downloadsubsurface-7c095419f7f30203995fedcde23da6d541cf078c.tar.gz
Cmake: consistently use SUBSURFACE_TARGET and get the capitalization right
Also clean up a bit of the whitespace mess right where I'm making changes Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 14 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7bf638399..e7fb224fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,12 +120,20 @@ include_directories(.
# if the configuration is too big or would disrupt the normal code flux,
# move it somewhere else (another file) and include it.
if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
- set(SUBSURFACE_TARGET subsurface)
+ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ set(SUBSURFACE_TARGET Subsurface)
+ else()
+ set(SUBSURFACE_TARGET subsurface)
+ endif()
elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
- set(SUBSURFACE_TARGET subsurface-mobile)
- list(APPEND QT_EXTRA_COMPONENTS Quick)
- list(APPEND QT_EXTRA_LIBRARIES Qt5::Quick)
- add_definitions(-DSUBSURFACE_MOBILE)
+ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ set(SUBSURFACE_TARGET Subsurface-mobile)
+ else()
+ set(SUBSURFACE_TARGET subsurface-mobile)
+ endif()
+ list(APPEND QT_EXTRA_COMPONENTS Quick)
+ list(APPEND QT_EXTRA_LIBRARIES Qt5::Quick)
+ add_definitions(-DSUBSURFACE_MOBILE)
endif()
if(ANDROID)
@@ -209,7 +217,6 @@ endif()
# create the executables
if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
- set(SUBSURFACE_TARGET subsurface-mobile)
set(MOBILE_SRC
qt-mobile/qmlmanager.cpp
qt-mobile/qmlprofile.cpp
@@ -411,7 +418,7 @@ elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
install(DIRECTORY printing_templates DESTINATION share/subsurface)
install(FILES ${TRANSLATIONS} DESTINATION share/subsurface/translations)
if(SUBSURFACE_MOBILE)
- install(TARGETS subsurface-mobile DESTINATION bin)
+ install(TARGETS ${SUBSURFACE_TARGET} DESTINATION bin)
else()
install(TARGETS ${SUBSURFACE_TARGET} DESTINATION bin)
if (SMARTTRAK_IMPORT)