summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2016-08-24 13:19:30 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-08-24 13:36:32 -0700
commita5cf8aaa21842d491c583a17c01340bb61e4d4ed (patch)
tree66aae5fab024224283f205ef5cd2a124fd6ab808 /CMakeLists.txt
parent7dd8a62ceddbb2205bd41260964f3450e72fccab (diff)
downloadsubsurface-a5cf8aaa21842d491c583a17c01340bb61e4d4ed.tar.gz
Android build: try to create APK that works on Android 7.0
It appears that instead of statically linking against ssl/crypto/ssh2, you instead have to dynamically link against it and then bundle the library in the APK. The documentation is not 100% clear and I don't have an Android Nougat device to test this with, so for now this is an attempt. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8efd34b2a..4ca1a4014 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -332,7 +332,7 @@ if(ANDROID)
# Android template directory
include(${QT_ANDROID_CMAKE})
add_qt_android_apk(${SUBSURFACE_TARGET}.apk ${SUBSURFACE_TARGET}
- PACKAGE_SOURCES ${CMAKE_BINARY_DIR}/android-mobile
+ PACKAGE_SOURCES ${CMAKE_BINARY_DIR}/android-mobile DEPENDS ${ANDROID_NATIVE_LIBSSL} ${ANDROID_NATIVE_LIBCRYPT} ${ANDROID_NATIVE_LIBSSH2}
)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(APP_BUNDLE_DIR "${SUBSURFACE_TARGET}.app")