summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-11-17 19:01:01 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-16 07:59:37 -0800
commitf26df4f80afc199c9a063f280bc60b0cf2006944 (patch)
treeb975e25b4100852f903e5ec9e26c2fa519fdfb98 /CMakeLists.txt
parent268fbf3fb152bba485b4924d2b686889d8b10532 (diff)
downloadsubsurface-f26df4f80afc199c9a063f280bc60b0cf2006944.tar.gz
Move Handling of user manual to Modules directory
Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a3bf27f1..0be935399 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,6 +91,7 @@ include(cmake/Modules/HandleFindLibDiveComputer.cmake)
include(cmake/Modules/HandleFindMarble.cmake)
include(cmake/Modules/HandleFindGrantlee.cmake)
include(cmake/Modules/HandleFtdiSupport.cmake)
+include(cmake/Modules/HandleUserManual.cmake)
include(cmake/Modules/HandleVersionGeneration.cmake)
pkg_config_library(LIBXML libxml-2.0 REQUIRED)
@@ -109,14 +110,6 @@ if(ANDROID)
set(NO_PRINTING ON)
endif()
-if(NO_USERMANUAL)
- message(STATUS "building without usermanual")
- add_definitions(-DNO_USERMANUAL)
-else()
- set(WEBKIT_PKG WebKitWidgets)
- set(WEBKIT_LIB Qt5::WebKitWidgets)
-endif()
-
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${LIBUSB_LIBRARIES})
# configure Qt.