summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-09-03 15:25:01 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-30 10:36:49 -0700
commit50ec7200e66637abefe685e1875f3d4de2101158 (patch)
treebee7515ccff2b70dfa0b66994d19950e6370e813 /CMakeLists.txt
parent45c97640739198cf9a9cc5c42e81fb9811702b46 (diff)
downloadsubsurface-50ec7200e66637abefe685e1875f3d4de2101158.tar.gz
Single CMake to handle the models
This one was pretty easy because of the work I did a few months ago to separate the models from the UI. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 4 insertions, 29 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 620b496ff..cdee60858 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -312,38 +312,16 @@ endif()
# include translations
add_subdirectory(translations)
add_subdirectory(subsurface-core)
+add_subdirectory(qt-models)
if(FBSUPPORT)
add_definitions(-DFBSUPPORT)
set(SOCIALNETWORKS qt-ui/socialnetworks.cpp)
endif()
-# the data models that will interface
-# with the views.
-set(SUBSURFACE_MODELS_LIB_SRCS
- qt-models/cleanertablemodel.cpp
- qt-models/cylindermodel.cpp
- qt-models/diveplannermodel.cpp
- qt-models/models.cpp
- qt-models/filtermodels.cpp
- qt-models/tankinfomodel.cpp
- qt-models/weigthsysteminfomodel.cpp
- qt-models/weightmodel.cpp
- qt-models/divecomputermodel.cpp
- qt-models/treemodel.cpp
- qt-models/tableprintmodel.cpp
- qt-models/yearlystatisticsmodel.cpp
- qt-models/divetripmodel.cpp
- qt-models/divecomputerextradatamodel.cpp
- qt-models/completionmodels.cpp
- qt-models/profileprintmodel.cpp
- qt-models/divepicturemodel.cpp
- qt-models/diveplotdatamodel.cpp
- qt-models/divelocationmodel.cpp
- qt-models/divesitepicturesmodel.cpp
- qt-models/ssrfsortfilterproxymodel.cpp
-)
-source_group("Subsurface Models" FILES ${SUBSURFACE_MODELS})
+if(BTSUPPORT)
+ add_definitions(-DBT_SUPPORT)
+endif()
# the main app.
set(SUBSURFACE_APP
@@ -353,9 +331,6 @@ set(SUBSURFACE_APP
source_group("Subsurface App" FILES ${SUBSURFACE_APP})
-add_library(subsurface_models STATIC ${SUBSURFACE_MODELS_LIB_SRCS})
-target_link_libraries(subsurface_models ${QT_LIBRARIES})
-
# add pthread to the end of the library list on Linux
# this is only needed on Ubuntu (why do these idiots break everything?)
# but shouldn't hurt on other Linux versions