summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-01-01 10:31:47 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-01-01 10:31:47 -0800
commit7312cfc2d0471b5ed8993cb7a94a8da86627a6a3 (patch)
tree1ca67e2a38ed9f1d3a4c08d0f0aeeef0d9b3bda9 /CMakeLists.txt
parentba23989e6b89a34747d084ea8a31ada6bdcd2d0f (diff)
downloadsubsurface-7312cfc2d0471b5ed8993cb7a94a8da86627a6a3.tar.gz
CMake: more changes to a simple conditional
It seems the CMake versions on Linux and Mac disagree about what might be the correct way to use parenthesis in a mixed AND/OR conditional. This may seem overkill, but it made both CMake versions happy. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30ed16d90..f67d57168 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,10 @@ set(CMAKE_MODULE_PATH
#
if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 ")
- if(${CMAKE_SYSTEM_NAME} MATCHES "Darwin" AND
- (${CMAKE_SYSTEM_VERSION} MATCHES "11.4." OR ${CMAKE_OSX_DEPLOYMENT_TARGET} MATCHES "10.7" OR ${CMAKE_OSX_DEPLOYMENT_TARGET} MATCHES "10.8"))
+ if((${CMAKE_SYSTEM_NAME} MATCHES "Darwin") AND
+ ((${CMAKE_SYSTEM_VERSION} MATCHES "11.4.") OR
+ (${CMAKE_OSX_DEPLOYMENT_TARGET} MATCHES "10.7") OR
+ (${CMAKE_OSX_DEPLOYMENT_TARGET} MATCHES "10.8")))
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -stdlib=libc++")
else()
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")