summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-03-25 15:02:21 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-03-25 15:02:21 -0700
commit4309ab4a16082963872e2bd5240e1c8bf6f4dddf (patch)
treeaeb75ab7e5d42a862c4bcf48b772e9af2416904f /CMakeLists.txt
parent405e52fef9d4a8eec16554496dfd8e8bad0476aa (diff)
downloadsubsurface-4309ab4a16082963872e2bd5240e1c8bf6f4dddf.tar.gz
cmake: setup marble link directory correctly
This way the necessary rpath settings are created Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2353d2742..941e4bc20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,9 +71,11 @@ SET(QT_TEST_LIBRARIES ${QT_LIBRARIES} Qt5::Test)
IF(NOT DEFINED LIBMARBLEDEVEL)
FIND_PACKAGE(Marble REQUIRED)
- INCLUDE_DIRECTORIES(${MARBLE_INCLUDE_DIR})
+ include_directories(${MARBLE_INCLUDE_DIR})
+ link_directories(${MARBLE_LIB_DIR})
ELSE()
- INCLUDE_DIRECTORIES(${LIBMARBLEDEVEL}/include)
+ include_directories(${LIBMARBLEDEVEL}/include)
+ link_directories(${LIBMARBLEDEVEL}/lib)
SET(MARBLE_LIBRARIES -L${LIBMARBLEDEVEL}/lib -lssrfmarblewidget)
ENDIF()