summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-08-25 09:02:15 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-08-25 09:02:55 -0700
commit2acdb32e83a6d7efd2c819f0efe333169e98fc39 (patch)
tree5f62acc0f8b572213cf24798e0c884cabc39d480 /CMakeLists.txt
parent12ea31ef78454d9cff45d0df52687739ee1f35de (diff)
downloadsubsurface-2acdb32e83a6d7efd2c819f0efe333169e98fc39.tar.gz
Enable googlemaps plugin from build directory on Linux
With this change, when running Subsurface from the build directory, it should find a googlemaps plugin that was installed into the install_root. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 763f8ec26..bd36966c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -480,6 +480,12 @@ elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
if(NOT NO_MARBLE)
install(DIRECTORY marbledata/maps DESTINATION share/subsurface/data)
install(DIRECTORY marbledata/bitmaps DESTINATION share/subsurface/data)
+ else()
+ add_custom_target(link_googlemaps_plugin ALL COMMAND
+ rm -rf ./geoservices &&
+ mkdir -p geoservices &&
+ ln -sf
+ ${CMAKE_SOURCE_DIR}/../install-root/usr/lib/qt/plugins/geoservices/libqtgeoservices_googlemaps.so ${CMAKE_BINARY_DIR}/geoservices)
endif()
install(FILES subsurface.debug DESTINATION bin)
install(FILES subsurface.desktop DESTINATION share/applications)