summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-09-17 15:40:16 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-09-17 15:40:16 -0700
commitae209a3d9f8ed36e2228834d421ff4a6ac345ad9 (patch)
tree046937d0c944d3b6ad8ff9a8c49ab8bdcc3136d9 /CMakeLists.txt
parent58b7c6f8ef703009e098351774b8db521cce48e3 (diff)
parent49fe120d9530682cf539d562c4ffcae3e195b9ab (diff)
downloadsubsurface-ae209a3d9f8ed36e2228834d421ff4a6ac345ad9.tar.gz
Merge branch 'macBLE' of github.com:Subsurface-divelog/subsurface
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b3aff8a6..c7314fbcd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -220,9 +220,8 @@ if (BTSUPPORT AND "${Qt5Core_VERSION}" VERSION_LESS 5.4.0)
endif()
# Windows Qt doesn't support BLE at all
-# Mac hasn't been tested, yet - so far it's disabled
# the rest of them need at least 5.6 to be reasonable but really, you want 5.9.1
-if (BTSUPPORT AND (ANDROID OR CMAKE_SYSTEM_NAME STREQUAL "Linux"))
+if (BTSUPPORT AND NOT CMAKE_SYSTEM_NAME STREQUAL "Windows")
if ("${Qt5Core_VERSION}" VERSION_LESS 5.6.0)
message(STATUS "Turning off BLE support as Qt version ${Qt5Core_VERSION} is insufficient for that")
else()