summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-04-07 16:53:28 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-07 16:07:07 -0700
commit057231701e68b5546c7ce373286b7999c93f3b04 (patch)
treee6f32c01f7ad6d3afd7f87cd4a4ac3457daad7df /CMakeLists.txt
parente56580229bd60e1363344fc4fb7439550f7392a4 (diff)
downloadsubsurface-057231701e68b5546c7ce373286b7999c93f3b04.tar.gz
Move the pkg_config_library macro to its own file
The pkg_config_library macro is a helper macro and was generating noise on the main CMakeLists.txt file, so I moved it to another file. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 381532c98..4ba2d3381 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,16 +17,8 @@ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUXX)
endif()
# pkgconfig for required libraries
-
FIND_PACKAGE(PkgConfig)
-
-MACRO(pkg_config_library LIBNAME pcfile)
- pkg_check_modules(${LIBNAME} REQUIRED ${pcfile})
- include_directories(${${LIBNAME}_INCLUDE_DIRS})
- link_directories(${${LIBNAME}_LIBRARY_DIRS})
- add_definitions(${${LIBNAME}_CFLAGS_OTHER})
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${${LIBNAME}_LIBRARIES})
-ENDMACRO()
+INCLUDE(cmake/Modules/pkgconfig_helper.cmake)
pkg_config_library(LIBXML libxml-2.0)
pkg_config_library(LIBSQLITE3 sqlite3)