summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-11 10:50:55 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-11 12:36:49 -0800
commit136b87e7c00b79ba8ee316ecf66dbc326e78c823 (patch)
tree855e8a706b27b243f2fafc270b6b6cf7e35f9d09 /CMakeLists.txt
parent111a153295dd50822dfe84da7b45ba06cac7bc84 (diff)
downloadsubsurface-136b87e7c00b79ba8ee316ecf66dbc326e78c823.tar.gz
Location service: Add GPS location infrastructure for Subsurface-mobile
This doesn't do a thing - just adds the empty class and sets up the Cmake file so it finds the required Qt components for Subsurface-mobile. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c587177d5..0f8e68053 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,6 +202,8 @@ endif()
if(SUBSURFACE_MOBILE)
set(QT_QUICK_PKG Quick)
set(QT_QUICK_LIB Qt5::Quick)
+ set(QT_LOCATION_PKG Location)
+ set(QT_LOCATION_LIB Qt5::Positioning)
endif()
if(ANDROID)
set(ANDROID_PKG AndroidExtras)
@@ -211,8 +213,8 @@ if(BTSUPPORT)
set(BLUETOOTH_PKG Bluetooth)
set(BLUETOOTH_LIB Qt5::Bluetooth)
endif()
-find_package(Qt5 REQUIRED COMPONENTS Core Concurrent Widgets Network ${WEBKIT_PKG} ${PRINTING_PKG} Svg Test LinguistTools ${QT_QUICK_PKG} ${ANDROID_PKG} ${BLUETOOTH_PKG})
-set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} ${PRINTING_LIB} Qt5::Svg ${QT_QUICK_LIB} ${ANDROID_LIB} ${BLUETOOTH_LIB})
+find_package(Qt5 REQUIRED COMPONENTS Core Concurrent Widgets Network ${WEBKIT_PKG} ${PRINTING_PKG} Svg Test LinguistTools ${QT_QUICK_PKG} ${ANDROID_PKG} Bluetooth ${QT_LOCATION_PKG})
+set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} ${PRINTING_LIB} Qt5::Svg ${QT_QUICK_LIB} ${ANDROID_LIB} Qt5::Bluetooth ${QT_LOCATION_LIB})
set(QT_TEST_LIBRARIES ${QT_LIBRARIES} Qt5::Test)
if (BTSUPPORT AND "${Qt5Core_VERSION_STRING}" STRLESS "5.4.0")
@@ -349,6 +351,7 @@ if(SUBSURFACE_MOBILE)
qt-models/divelistmodel.cpp
subsurface-mobile-main.cpp
subsurface-mobile-helper.cpp
+ gpslocation.cpp
)
add_definitions(-DSUBSURFACE_MOBILE)
qt5_add_resources(MOBILE_RESOURCES qt-mobile/qml/mobile-resources.qrc)