summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-07-15 21:51:42 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-07-15 21:51:42 -0700
commit20f5609a6c1c9717ffe04d51f764f03ec95ceaa1 (patch)
tree06f6dc73d5dde207143b743443b2237352615426 /CMakeLists.txt
parenta629eb70708505bcac38afb709b1958e21e90374 (diff)
downloadsubsurface-20f5609a6c1c9717ffe04d51f764f03ec95ceaa1.tar.gz
Mac build: correctly deal with no printing
Including working around a weird hack to install the Grantlee plugins. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ed2e08b7..beb86adbe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -397,7 +397,7 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
install(FILES ${QTTRANSLATIONS} DESTINATION ${RESOURCEDIR}/translations)
install(FILES ${CMAKE_SOURCE_DIR}/gpl-2.0.txt DESTINATION ${RESOURCEDIR})
# this is a HACK
- if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
+ if((${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable") AND (NOT NO_PRINTING))
install(DIRECTORY ${Grantlee5_DIR}/../../grantlee DESTINATION ${PLUGINDIR})
endif()
# this is a hack - but I don't know how else to find the macdeployqt program if it's not in the PATH