summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-24 11:02:45 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-24 11:02:45 -0700
commit38ba7177c772e2ee55396968833f9427c1a6bffc (patch)
treec30bbd2aa89e20aca6ba23985f621eb3bfca4529 /CMakeLists.txt
parent541e67ba416611c8f40bc53a8088dad294b347f3 (diff)
downloadsubsurface-38ba7177c772e2ee55396968833f9427c1a6bffc.tar.gz
cmake: copy images / icons into the build Documentation folder
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc7250136..39d09a5b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -377,7 +377,12 @@ if(NOT NO_TESTS)
endif()
if(NOT NO_DOCS)
- add_custom_target(documentation ALL mkdir -p ${CMAKE_BINARY_DIR}/Documentation/ \\; make -C ${CMAKE_SOURCE_DIR}/Documentation OUT=${CMAKE_BINARY_DIR}/Documentation/ doc)
+ add_custom_target(
+ documentation ALL
+ mkdir -p ${CMAKE_BINARY_DIR}/Documentation/ \\;
+ cp -a ${CMAKE_SOURCE_DIR}/Documentation/images ${CMAKE_BINARY_DIR}/Documentation/ \\;
+ make -C ${CMAKE_SOURCE_DIR}/Documentation OUT=${CMAKE_BINARY_DIR}/Documentation/ doc
+ )
endif()
# install Subsurface