summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2018-07-06 17:23:54 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-07-06 17:23:54 -0700
commit4595ccb9f993160eee25f242feb092566dfe3061 (patch)
tree6932553ea9ccbed2de7a8658a58557d93e9f1920 /CMakeLists.txt
parent80bc47fa132b9928e57d6a23f54b6db763abe494 (diff)
downloadsubsurface-4595ccb9f993160eee25f242feb092566dfe3061.tar.gz
build-system/macOS: copy one more library when building against Qt5.11
I don't quite understand why this one is missing, but otherwise the map doesn't work. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5212c6e4d..d02ac6112 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -446,6 +446,10 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
install(CODE "execute_process(COMMAND cp -a ${_qt5Core_install_prefix}/qml/QtQuick.2 ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Resources/qml)")
install(CODE "execute_process(COMMAND cp -a ${_qt5Core_install_prefix}/qml/QtLocation ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Resources/qml)")
install(CODE "execute_process(COMMAND cp -a ${_qt5Core_install_prefix}/qml/QtPositioning ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Resources/qml)")
+ if(NOT Qt5Core_VERSION VERSION_LESS 5.11.0)
+ # and with Qt 5.11 we need another library that isn't copied by macdeployqt
+ install(CODE "execute_process(COMMAND cp -a ${_qt5Core_install_prefix}/lib/QtPositioningQuick.framework ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Frameworks)")
+ endif()
if((${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable"))
install(CODE "execute_process(COMMAND cp -a ${_qt5Core_install_prefix}/qml/QtQuick ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Resources/qml)")
install(CODE "execute_process(COMMAND cp -a ${_qt5Core_install_prefix}/qml/QtGraphicalEffects ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Resources/qml)")