summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Robert C. Helling <helling@atdotde.de>2020-10-11 16:27:28 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-10-11 08:40:38 -0700
commit48adaf52971965a0e1465ea834cbe930d3c65ec4 (patch)
tree8b43939f79cebb39cb5015a0565b24226cd50b57 /CMakeLists.txt
parentc9b8584bd2b7559008e57daf4359c02bad94d262 (diff)
downloadsubsurface-48adaf52971965a0e1465ea834cbe930d3c65ec4.tar.gz
Set the NO_PRINTING variable properly
Signed-off-by: Robert C. Helling <helling@atdotde.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1d61b557..e4773efca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -175,8 +175,10 @@ if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
endif()
list(APPEND QT_EXTRA_COMPONENTS QuickWidgets)
remove_definitions(-DSUBSURFACE_MOBILE)
- # I hate the double negation
- if(NOT NO_PRINTING)
+ if(NO_PRINTING)
+ message(STATUS "building without printing support")
+ add_definitions(-DNO_PRINTING)
+ else()
LIST(APPEND QT_EXTRA_COMPONENTS PrintSupport)
# Because Qt5WebKitWidgets isn't a part of the "regular" Qt5, we can't get it the normal way
find_package(Qt5WebKitWidgets REQUIRED)