summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-07-28 17:18:09 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-07-28 22:03:22 -0700
commit939d7ee804a15c0f0c89fc964d100095cecf4b03 (patch)
tree21f36c4f227c3eb7b27ca16ce3ad270089ddebb5 /CMakeLists.txt
parent8a35794632d2a34e366288540a32b22f48f40cd6 (diff)
downloadsubsurface-939d7ee804a15c0f0c89fc964d100095cecf4b03.tar.gz
cmake: only install Marble files when we use Marble
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 12 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 56cf02456..4873f44e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -393,8 +393,10 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(MACDEPLOY_ARGS "${EXTRA_MACDEPLOY_ARGS}-executable=${APP_BUNDLE_DIR}/Contents/MacOS/${SUBSURFACE_TARGET} -always-overwrite")
set(RESOURCEDIR ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Resources)
set(PLUGINDIR ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/PlugIns)
- install(DIRECTORY marbledata/maps DESTINATION ${RESOURCEDIR}/data)
- install(DIRECTORY marbledata/bitmaps DESTINATION ${RESOURCEDIR}/data)
+ if(NOT NO_MARBLE)
+ install(DIRECTORY marbledata/maps DESTINATION ${RESOURCEDIR}/data)
+ install(DIRECTORY marbledata/bitmaps DESTINATION ${RESOURCEDIR}/data)
+ endif()
install(DIRECTORY Documentation/images DESTINATION ${RESOURCEDIR}/share/Documentation)
install(FILES ${DOCFILES} DESTINATION ${RESOURCEDIR}/share/Documentation)
install(DIRECTORY theme DESTINATION ${RESOURCEDIR})
@@ -434,8 +436,10 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Windows")
# "make install", copies everything into a staging area
# "make installer", uses makensis to create an installer executable
set(WINDOWSSTAGING ${CMAKE_BINARY_DIR}/staging)
- install(DIRECTORY marbledata/maps DESTINATION ${WINDOWSSTAGING}/data)
- install(DIRECTORY marbledata/bitmaps DESTINATION ${WINDOWSSTAGING}/data)
+ if(NOT NO_MARBLE)
+ install(DIRECTORY marbledata/maps DESTINATION ${WINDOWSSTAGING}/data)
+ install(DIRECTORY marbledata/bitmaps DESTINATION ${WINDOWSSTAGING}/data)
+ endif()
install(DIRECTORY Documentation/images DESTINATION ${WINDOWSSTAGING}/Documentation)
install(FILES ${DOCFILES} DESTINATION ${WINDOWSSTAGING}/Documentation)
install(DIRECTORY theme DESTINATION ${WINDOWSSTAGING})
@@ -470,8 +474,10 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Windows")
DEPENDS fake_install
)
elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
- install(DIRECTORY marbledata/maps DESTINATION share/subsurface/data)
- install(DIRECTORY marbledata/bitmaps DESTINATION share/subsurface/data)
+ if(NOT NO_MARBLE)
+ install(DIRECTORY marbledata/maps DESTINATION share/subsurface/data)
+ install(DIRECTORY marbledata/bitmaps DESTINATION share/subsurface/data)
+ endif()
install(FILES subsurface.debug DESTINATION bin)
install(FILES subsurface.desktop DESTINATION share/applications)
install(FILES icons/subsurface-icon.svg DESTINATION share/icons/hicolor/scalable/apps)