summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jan Mulder <jlmulder@xs4all.nl>2018-01-02 17:02:19 +0100
committerGravatar Jan Mulder <jlmulder@xs4all.nl>2018-01-03 14:04:08 +0100
commita5b44362c62b303fa1cedaa633588243b264bfa0 (patch)
tree53627b511f3d2e75b496c0f0398965354d37d9ae /CMakeLists.txt
parent7a48149868d4e0bda6e7930165722368224f596d (diff)
downloadsubsurface-a5b44362c62b303fa1cedaa633588243b264bfa0.tar.gz
mobile: newer Kirigami SHA
This commit consists of the following 3 parts: 1. There are 2 source files added, adapt our build process accordingly. 2. Due to a change in icon and kirigami QML prefixes, we need to adapt for this as well. Changed mobile-resources.qrc for that. When this would not be changed, the icons will not be found. 3. To further prepare for the future, abandon the iconName property in favour of the new icon grouped property, which can have more attributes than only the name. But currently it is only a syntactic change. Tested on Android device, and no visible changes. Signedoff-by: Jan Mulder <jlmulder@xs4all.nl
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 011d4d776..d4de6a6fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -286,6 +286,8 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
mobile-widgets/qml/kirigami/src/kirigamiplugin.cpp
mobile-widgets/qml/kirigami/src/settings.cpp
mobile-widgets/qml/kirigami/src/enums.cpp
+ mobile-widgets/qml/kirigami/src/formlayoutattached.cpp
+ mobile-widgets/qml/kirigami/src/mnemonicattached.cpp
mobile-widgets/qml/kirigami/src/libkirigami/basictheme.cpp
mobile-widgets/qml/kirigami/src/libkirigami/kirigamipluginfactory.cpp
mobile-widgets/qml/kirigami/src/libkirigami/platformtheme.cpp