summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-03-03 22:31:59 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-05 13:27:54 -0800
commitb702e8e2257c259d5d4ab2ec1547057d525e03af (patch)
tree65ec060e6fc248eb0fd54bd82ec1e4e268a0056a /CMakeLists.txt
parent47e9a771ba8fef590b240923e68edf6402242354 (diff)
downloadsubsurface-b702e8e2257c259d5d4ab2ec1547057d525e03af.tar.gz
CMake: tell the Intel compiler to use the correct C/C++ standards
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e5630c49..54ce2f11d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,7 +95,9 @@ elseif (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
endif()
elseif (CMAKE_CXX_COMPILER_ID STREQUAL "Intel")
- # using Intel C++
+ # works only for CMake 3.1 and later
+ set(CMAKE_C_STANDARD 99)
+ set(CMAKE_CXX_STANDARD 11)
elseif (CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
# using Visual Studio C++
endif()