summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-05-01 19:17:22 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-05-01 19:17:22 -0700
commite491f4a0db4d36fe659251f7e404b9cfaea7fee0 (patch)
tree8d3181218a60c1a7fc97e03bbc324048442eeff0 /CMakeLists.txt
parentc21883c4190c83dd6feb8b033ca653e2e55e91fa (diff)
downloadsubsurface-e491f4a0db4d36fe659251f7e404b9cfaea7fee0.tar.gz
cmake: enable Facebook support
Not sure if we have this on Android, so right now I just enable it for Linux, OS X, and Windows. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4ebdd6f6..13ea10a25 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -146,12 +146,14 @@ add_custom_target(
set(PLATFORM_SRC unknown_platform.c)
if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ set(FBSUPPORT 1)
set(SUBSURFACE_TARGET subsurface)
set(PLATFORM_SRC linux.c)
# in some builds we appear to be missing libz for some strange reason...
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lz)
endif()
if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ set(FBSUPPORT 1)
set(SUBSURFACE_TARGET Subsurface)
set(PLATFORM_SRC macos.c)
find_library(APP_SERVICES_LIBRARY ApplicationServices)
@@ -169,6 +171,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(SUBSURFACE_PKG MACOSX_BUNDLE ${ICON_FILE})
endif()
if(CMAKE_SYSTEM_NAME STREQUAL "Windows")
+ set(FBSUPPORT 1)
set(SUBSURFACE_TARGET subsurface)
set(PLATFORM_SRC windows.c)
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lwsock32)
@@ -227,6 +230,10 @@ set(SUBSURFACE_CORE_LIB_SRCS
${PLATFORM_SRC}
)
+if(FBSUPPORT)
+ add_definitions(-DFBSUPPORT)
+ set(SOCIALNETWORKS qt-ui/socialnetworks.cpp)
+endif()
# the interface, in C++
set(SUBSURFACE_INTERFACE
@@ -265,6 +272,7 @@ set(SUBSURFACE_INTERFACE
qt-ui/configuredivecomputerdialog.cpp
qt-ui/filtermodels.cpp
qt-ui/undocommands.cpp
+ ${SOCIALNETWORKS}
)
# the profile widget