summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2016-09-22 17:12:00 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-09-22 17:12:00 -0700
commit131c5a2abe151493b23b42469834aa5c9891459b (patch)
treee079916289d2b5cfb1d09bad1f51175df7d7cbbb /CMakeLists.txt
parent78dc3a3efe83c66a7cb31677704e1570bf8a3a4a (diff)
downloadsubsurface-131c5a2abe151493b23b42469834aa5c9891459b.tar.gz
Fix building of Facebook support
No idea when this got broken. Fix seems like a hack as that variable should get set in the plugin CMakeLists.txt. But it seems to work, so "whatever". Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 095160c7d..09afcf882 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -267,6 +267,9 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
target_link_libraries(smtk2ssrf smtk_import)
endif()
+ if(FBSUPPORT)
+ set(FACEBOOK_INTEGRATION facebook_integration)
+ endif()
target_link_libraries(
${SUBSURFACE_TARGET}
subsurface_generated_ui