summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Marco Martin <notmart@gmail.com>2016-06-22 18:17:25 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-08-14 07:56:05 -0700
commit24718adfc3c2d7caaddd307289ba69fa706315c9 (patch)
tree39ede99be41e6908e73d1899c9d5ab071bf363a7 /CMakeLists.txt
parent545c60a517402346aa04e2b67284827d510ec71d (diff)
downloadsubsurface-24718adfc3c2d7caaddd307289ba69fa706315c9.tar.gz
Use kirigami built in static mode
Now kirigami needs to be built with a C++ plugin. In cases of mobile operating systems such as iOS (and in a lesser measuse, Android) having a proper plugin loaded at runtime may be difficult, so statically link it together with all of its qml files compiled as a qresource inside the static library. Signed-off-by: Marco Martin <notmart@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7aac06f6b..dea200c36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -238,12 +238,16 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
else()
add_executable(${SUBSURFACE_TARGET} MACOSX_BUNDLE WIN32 ${SUBSURFACE_PKG} ${MOBILE_SRC} ${SUBSURFACE_RESOURCES} ${MOBILE_RESOURCES})
endif()
+ ADD_LIBRARY(kirigami_static_library STATIC IMPORTED)
+ SET_TARGET_PROPERTIES(kirigami_static_library PROPERTIES
+ IMPORTED_LOCATION ${CMAKE_SOURCE_DIR}/mobile-widgets/qml/kirigami/build/src/libkirigamiplugin.a)
target_link_libraries(
${SUBSURFACE_TARGET}
subsurface_profile
subsurface_models
subsurface_corelib
${SUBSURFACE_LINK_LIBRARIES}
+ kirigami_static_library
)
elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
set(SUBSURFACE_APP