summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Anton Lundin <glance@acc.umu.se>2015-12-01 20:46:59 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-02 09:21:04 -0800
commit59042b2ed0d260345fd48a940fd0bd5b043a1445 (patch)
tree88ee9fc0e36ac3a2238811d80afa31ebf0e3fef9 /CMakeLists.txt
parent58901690dd1d6e8c7bbfc5099f43bfa8f9a955b8 (diff)
downloadsubsurface-59042b2ed0d260345fd48a940fd0bd5b043a1445.tar.gz
Fix disabling of facebook integration
Signed-off-by: Anton Lundin <glance@acc.umu.se> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c53846788..47dea0497 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,10 @@ option(FTDISUPPORT "enable support for libftdi based serial" OFF)
option(DISABLE_PLUGINS "disable support for social media plugins" OFF)
option(SMARTTRAK_IMPORT "enable building SmartTrak divelogs import tool (requires glib2 and libmdb)" OFF)
+if (NOT FBSUPPORT)
+ set(DISABLE_PLUGINS ON)
+endif()
+
add_definitions(-DSUBSURFACE_SOURCE="${CMAKE_SOURCE_DIR}")
set(CMAKE_MODULE_PATH
@@ -344,9 +348,9 @@ endif()
if(FBSUPPORT)
add_definitions(-DFBSUPPORT)
+ set(FACEBOOK_INTEGRATION facebook_integration)
endif()
-
# add pthread to the end of the library list on Linux
# this is only needed on Ubuntu (why do these idiots break everything?)
# but shouldn't hurt on other Linux versions
@@ -407,7 +411,7 @@ else()
${SUBSURFACE_TARGET}
subsurface_generated_ui
subsurface_interface
- facebook_integration
+ ${FACEBOOK_INTEGRATION}
subsurface_profile
subsurface_statistics
subsurface_models