summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2016-01-08 13:11:49 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-01-08 08:04:04 -0800
commit89eed5d36e611f882dbf1e2686ad389f65688fa1 (patch)
treeb7e185df6424d46c9d992ea388a03d4a6b19fd7e /CMakeLists.txt
parent7b155774c5105f84303e869317fc946b11b3e78b (diff)
downloadsubsurface-89eed5d36e611f882dbf1e2686ad389f65688fa1.tar.gz
Untangle Library Linkage
with the adittion of gpslistmodel/location, the libraries qt-models had a direct dependency on subsurface-core, and subsurface-core had a direct dependency on qt-models, this is bad. Moving a bit of code around I'v managed to clean this out, and also to clear a bit of uneeded code (GpsTracker and gpsTracker where basically the same thing.) Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18101e087..548045759 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -225,8 +225,6 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
set(MOBILE_SRC
qt-mobile/qmlmanager.cpp
qt-mobile/qmlprofile.cpp
- qt-models/divelistmodel.cpp
- qt-models/gpslistmodel.cpp
subsurface-mobile-main.cpp
subsurface-mobile-helper.cpp
)