summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Sebastian Kügler <sebas@kde.org>2015-11-07 00:39:06 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-07 09:00:59 -0800
commitaae4a326f4738be368088f0d0f7a91d75b02a9ad (patch)
tree937c2253e015da2a127285e957a98f785b5cfc94 /CMakeLists.txt
parent95ac4c4454aa49326500639aab839eb3d11efa87 (diff)
downloadsubsurface-aae4a326f4738be368088f0d0f7a91d75b02a9ad.tar.gz
organize qml files in subdirectories
This makes the organization of the qml files a bit more fine-grained, it prevents mixing of .cpp and QML files, and also of what's compiled, and what's included in the app as qrc data. In particular: - subsurface specific QML items go into the qml/ subdirectory - theme and unit definitions to into qml/theme subdirectory (they already were located in a theme directory) - generic components, such as our Label goes into qml/components This facilitates sharing of functionality and identifying common stuff better. Ideally, we can pull qml/theme and qml/components from a standardized set at some point, so we don't have to maintain that code. Signed-off-by: Sebastian Kügler <sebas@kde.org> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98456b13f..d45ca4321 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -353,7 +353,7 @@ if(SUBSURFACE_MOBILE)
subsurface-mobile-helper.cpp
)
add_definitions(-DSUBSURFACE_MOBILE)
- qt5_add_resources(MOBILE_RESOURCES qt-mobile/mobile-resources.qrc)
+ qt5_add_resources(MOBILE_RESOURCES qt-mobile/qml/mobile-resources.qrc)
if(ANDROID)
add_library(subsurface-mobile SHARED ${MOBILE_SRC} ${SUBSURFACE_PKG} ${SUBSURFACE_RESOURCES} ${MOBILE_RESOURCES})
else()