summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Alexander Wilms <f.alexander.wilms@gmail.com>2018-09-03 22:04:50 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-09-09 18:43:30 -0700
commitbcf568586de30be23bd5ff37746b6b4eb1140167 (patch)
treef69e7d1cd000457e816b42a684ad1eb150bb350e /CMakeLists.txt
parent39b52d8abff9f8bd91c5e5031eb8f9f48a92f3bb (diff)
downloadsubsurface-bcf568586de30be23bd5ff37746b6b4eb1140167.tar.gz
Fix appdata
Use correct format, create script to update the version and release date in the appdata. [Dirk Hohndel: call said script during the build process] Signed-off-by: Alexander Wilms <f.alexander.wilms@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c967ca548..a4a82f640 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -519,6 +519,7 @@ elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
endif()
install(FILES subsurface.debug DESTINATION bin)
install(FILES subsurface.desktop DESTINATION share/applications)
+ install(CODE "execute_process(COMMAND sh ${CMAKE_SOURCE_DIR}/scripts/add-version-to-appdata.sh WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})")
install(FILES appdata/subsurface.appdata.xml DESTINATION share/metainfo)
install(FILES icons/subsurface-icon.svg DESTINATION share/icons/hicolor/scalable/apps)
install(DIRECTORY Documentation/images DESTINATION share/subsurface/Documentation)