summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-09-16 20:13:36 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-09-17 09:54:04 -0700
commit08e4d2dc5ec4c3ca9eca7d56bb380ae124088b06 (patch)
tree9e780b758cc6de3f232d3587f42b4e8ce7042fc7 /CMakeLists.txt
parent2d2bb95482f29ffdee476322e7fca56d725c3fb6 (diff)
downloadsubsurface-08e4d2dc5ec4c3ca9eca7d56bb380ae124088b06.tar.gz
cmake: enable BLE on Macs
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b3aff8a6..c7314fbcd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -220,9 +220,8 @@ if (BTSUPPORT AND "${Qt5Core_VERSION}" VERSION_LESS 5.4.0)
endif()
# Windows Qt doesn't support BLE at all
-# Mac hasn't been tested, yet - so far it's disabled
# the rest of them need at least 5.6 to be reasonable but really, you want 5.9.1
-if (BTSUPPORT AND (ANDROID OR CMAKE_SYSTEM_NAME STREQUAL "Linux"))
+if (BTSUPPORT AND NOT CMAKE_SYSTEM_NAME STREQUAL "Windows")
if ("${Qt5Core_VERSION}" VERSION_LESS 5.6.0)
message(STATUS "Turning off BLE support as Qt version ${Qt5Core_VERSION} is insufficient for that")
else()