summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Alexander Wilms <Alexander-Wilms@users.noreply.github.com>2018-07-09 02:50:58 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-07-08 20:24:24 -0700
commit12519af8b4340cc5c8e7f95f534f1736a77b4ef5 (patch)
tree4c962340ec05150f7ec30af15af568f900e3a111 /CMakeLists.txt
parentfe2f665ebecff0b92ec449bd4da2134551cced77 (diff)
downloadsubsurface-12519af8b4340cc5c8e7f95f534f1736a77b4ef5.tar.gz
Install subsurface.appdata.xml
This is required to make Subsurface show up in Gnome Software & KDE Discover Signed-off-by: Alexander Wilms <f.alexander.wilms@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a58321360..7b81c40b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -526,6 +526,7 @@ elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
endif()
install(FILES subsurface.debug DESTINATION bin)
install(FILES subsurface.desktop DESTINATION share/applications)
+ install(FILES appdata/subsurface.appdata.xml DESTINATION share/metainfo)
install(FILES icons/subsurface-icon.svg DESTINATION share/icons/hicolor/scalable/apps)
install(DIRECTORY Documentation/images DESTINATION share/subsurface/Documentation)
install(FILES ${DOCFILES} DESTINATION share/subsurface/Documentation)