summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-03-03 21:59:42 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-05 13:27:54 -0800
commit69508d7123264ab3fa6ba6bf7ffba93784116563 (patch)
treef0ab3b944fe931dfdbb6e7746bd659b5867024d9 /CMakeLists.txt
parent9b5f6e16e1ec89ca8f5478e9da0d9a3a67bbf249 (diff)
downloadsubsurface-69508d7123264ab3fa6ba6bf7ffba93784116563.tar.gz
CMake: simplify checking if policy can be set
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9addef0c..7638f6e11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,9 +6,8 @@
project(Subsurface)
cmake_minimum_required(VERSION 2.8.11)
-# don't process generated files - this is new in 3.10 - but
-# VERSION_GREATER_EQUAL did get added until 3.7
-if(${CMAKE_VERSION} VERSION_EQUAL "3.10.0" OR ${CMAKE_VERSION} VERSION_GREATER "3.10.0")
+# don't process generated files - this is new in 3.10
+if (POLICY CMP0071)
cmake_policy(SET CMP0071 OLD)
endif()