summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2016-01-07 14:38:16 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-01-08 08:04:24 -0800
commit219299dc0121cf23a7bf49a38af90a751ef186a4 (patch)
treedd6a11744d170fc6c691c61efe9cc89362f2829e /CMakeLists.txt
parent89eed5d36e611f882dbf1e2686ad389f65688fa1 (diff)
downloadsubsurface-219299dc0121cf23a7bf49a38af90a751ef186a4.tar.gz
Correctly handle SubsurfaceMobile
Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 548045759..13f34fd00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -127,6 +127,7 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
else()
set(SUBSURFACE_TARGET subsurface)
endif()
+ remove_definitions(-DSUBSURFACE_MOBILE)
elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(SUBSURFACE_TARGET Subsurface-mobile)
@@ -423,14 +424,10 @@ elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
install(DIRECTORY theme DESTINATION share/subsurface)
install(DIRECTORY printing_templates DESTINATION share/subsurface)
install(FILES ${TRANSLATIONS} DESTINATION share/subsurface/translations)
- if(SUBSURFACE_MOBILE)
- install(TARGETS ${SUBSURFACE_TARGET} DESTINATION bin)
- else()
- install(TARGETS ${SUBSURFACE_TARGET} DESTINATION bin)
- if (SMARTTRAK_IMPORT)
- install(TARGETS ${SMTK_IMPORT_TARGET} DESTINATION bin)
- endif()
- endif()
+ install(TARGETS ${SUBSURFACE_TARGET} DESTINATION bin)
+ if (SMARTTRAK_IMPORT)
+ install(TARGETS ${SMTK_IMPORT_TARGET} DESTINATION bin)
+ endif()
if(DEFINED LIBMARBLEDEVEL)
install(
CODE "file(GLOB SSRFMARBLE_SHLIBS \"${LIBMARBLEDEVEL}/lib/libssrfmarblewidget.so*\")"